gem version

Passenger APT repository (.deb packages)

Relevant selection for this article:

Nginx

We provide APT repositories for installing Passenger on Debian and Ubuntu systems. There are separate repositories for the open source and Enterprise versions.

If you use these packages to install Passenger then you do not need to run passenger-install-nginx-module. These packages contain all the binaries that you need, including a Passenger-enabled Nginx binary.

Table of contents

  1. Loading...

Using the APT repository

Install latest Passenger + Nginx from APT

Please read the installation guide. When asked to select an installation method, select "Debian, Ubuntu".

Upgrade an APT-installed Passenger + Nginx

Please read the upgrade guide.

Uninstall an APT-installed Passenger + Nginx

Please read the uninstallation guide.

Background information and release policy

Multiple versions, multiple distributions

Our APT repositories contain Passenger packages for multiple versions of Debian and Ubuntu.

Always up-to-date

Our p packages are automatically built by our build server after we push out a source release, and thus are always up to date with the official source releases.

Limited architectures

Packages are available for the x86 and x86_64 architectures only.

Limited package support for non-LTS Ubuntu versions

Our policy is to support all Ubuntu LTS releases that are still supported by Canonical, plus the latest Ubuntu release, plus all Debian releases that are still supported by Debian.

Some Ubuntu releases are Long Term Supported (LTS) by Canonical, the company that created Ubuntu, for a period of 5 years. Other (non-LTS) Ubuntu versions are only supported by Canonical for 1 year.

We provide Passenger package updates for LTS Ubuntu versions for 5 years. But for non-LTS Ubuntu versions, we only provide Passenger package updates for 6 months. That is around the time when the next Ubuntu version is out.

So if you are using a non-LTS Ubuntu version, then when the next Ubuntu version is released, you must upgrade your system to that new Ubuntu version. Otherwise you won't receive Passenger updates in the form of .deb packages from us anymore.

light mode dark mode
Passenger 6 Passenger 6

Was this article helpful?

Yes No

Thanks for your feedback!